Customer Fields email delivery problems

Incident Report for Helium Development

Resolved

Email services and deliverability have recovered and we are not seeing any current problems. We have also put in place additional protections to help prevent further disruptions.
Posted Aug 05, 2026 - 09:41 PDT

Monitoring

Email services have been restored. Our team will monitor for any new or ongoing problems.
Posted Aug 04, 2026 - 17:32 PDT

Identified

We are seeing new problems with email deliverability. Our team is investigating and in contact with our email service provider.
Posted Aug 04, 2026 - 15:19 PDT
This incident affected: Customer Fields app for Shopify (Customer Fields: Email Notifications).