We've deployed an update to circumvent the problem we were seeing with Shopify's API responses.
Posted May 11, 2026 - 11:25 PDT
Identified
We've identified that the app's API calls to Shopify are timing out causing instability in the app, we are continuing to investigate and diagnose any problems on our end
Posted May 11, 2026 - 09:31 PDT
Investigating
The admin interface for the Meteor Mega Menu app is currently seeing increased loading times and may also see errors or incorrect content
Posted May 11, 2026 - 08:46 PDT
This incident affected: Meteor Mega Menus app for Shopify (Meteor Mega Menus: Admin UI).