Metafield creation failing in Shopify API

Incident Report for Helium Development

Resolved

We have deployed an API update to ensure that correct functionality is occurring for the Customer Fields app
Posted Jul 16, 2025 - 12:24 PDT

Identified

When creating a new data column or custom field in the Customer Fields app using the app's default namespace, the corresponding metafield in Shopify is not being created correctly due to a problem with the Shopify Admin API.
Posted Jul 16, 2025 - 11:06 PDT
This incident affected: Customer Fields app for Shopify (Customer Fields: Admin UI) and Shopify API & Mobile.