Forms are getting stuck during submission
Incident Report for Helium Development
Resolved
This incident has been resolved.
Posted May 02, 2024 - 13:52 PDT
Monitoring
Fixes for both problems have been implemented and we are currently monitoring the results.
Posted May 02, 2024 - 12:39 PDT
Update
Both problems have been identified and fixes for each are in the works
Posted May 02, 2024 - 10:59 PDT
Identified
We have noticed at least two problems with form submissions. One of the problems has been identified and a fix is being implemented
Posted May 02, 2024 - 10:08 PDT
Investigating
A select number of shops are having problems with form submissions on the storefront. We are currently investigating the issue.
Posted May 02, 2024 - 09:58 PDT
This incident affected: Customer Fields app for Shopify (Customer Fields: Store embeds).