Delayed processing of Shopify webhooks
Incident Report for Helium Development
Resolved
This incident has been resolved. The app's backend has finished processing all of the backlogged webhooks, and future webhooks should be processed without delay.
Posted Aug 29, 2022 - 15:32 PDT
Update
We are continuing to monitor for any further issues.
Posted Aug 29, 2022 - 12:09 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Aug 29, 2022 - 10:50 PDT
Update
We are continuing to work on a fix for this issue.
Posted Aug 29, 2022 - 09:41 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted Aug 29, 2022 - 09:03 PDT
Investigating
Certain shops may notice a delay when attempting to view changes to customer records in the app
Posted Aug 29, 2022 - 09:01 PDT
This incident affected: Customer Fields app for Shopify (Customer Fields: Admin UI, Customer Fields: Shopify webhooks, Customer Fields: Email Notifications).