Forms may be failing to load

Incident Report for Helium Development

Resolved

This incident has been resolved.
Posted May 12, 2025 - 23:00 PDT

Monitoring

Fixes have been implemented and we will continue to monitor the situation.
Posted May 12, 2025 - 20:18 PDT

Identified

Our team has identified system issues and are working on implementing solutions. We may continue to experience intermittent or partial outages.
Posted May 12, 2025 - 19:58 PDT

Update

We are continuing to investigate this issue.
Posted May 12, 2025 - 19:44 PDT

Investigating

We are currently investigating the issue
Posted May 12, 2025 - 19:44 PDT
This incident affected: Customer Fields app for Shopify (Customer Fields: Store embeds).