Google Cloud is reporting that their services are mostly recovered, and Helium's apps and services seem to be fully operational, although some intermittent or localized problems may still be experienced until full recovery.
Posted Jun 12, 2025 - 13:24 PDT
Identified
Widespread internet outages for services such as Google Cloud and Cloudflare may be affecting Helium's apps and services as well as Shopify itself.
Posted Jun 12, 2025 - 12:29 PDT
This incident affected: Customer Fields app for Shopify (Customer Fields: Admin UI, Customer Fields: Store embeds, Customer Fields: API, Customer Fields: Shopify webhooks, Customer Fields: Email Notifications), Meteor Mega Menus app for Shopify (Meteor Mega Menus: Admin UI, Meteor Mega Menus: Store embeds), and Google Cloud Platform Google Cloud SQL, Google Cloud Platform Google Cloud Storage, Google Cloud Platform Google Cloud Pub/Sub, Google Cloud Platform Google Kubernetes Engine, Google Cloud Platform Google Compute Engine, Google Cloud Platform Identity & Access Management.