Metafield updates are delayed
Incident Report for Helium Development
Resolved
This incident has fully resolved by Shopify. Shopify's system is no longer caching metafield values on the frontend. All app-related issues regarding access tokens and custom data should now be fixed.
Posted Feb 23, 2022 - 07:37 PST
Monitoring
Shopify has confirmed that the metafield caching is a platform wide issue and a fix is being implemented. Most stores that use Customer Fields have already been fixed. We are continuing to monitor Shopify's rollout of the fix and we'll post another update shortly.
Posted Feb 22, 2022 - 14:38 PST
Update
Shopify is still working on the issue. We'll post another update as soon as there is more progress to report.
Posted Feb 18, 2022 - 09:42 PST
Identified
The root cause of the issue has been identified. Shopify's system seems to be caching metafield values for frontend requests. We are actively working with Shopify to resolve the problem.
Posted Feb 17, 2022 - 10:38 PST
Investigating
Metafield updates are not being reflected in real-time. This is causing problems with customer access tokens and custom data. We are currently investigating this issue.
Posted Feb 17, 2022 - 10:13 PST
This incident affected: Customer Fields app for Shopify (Customer Fields: Store embeds).