Issues with form submissions and customer logins
Incident Report for Helium Development
Resolved
This incident has been resolved.
Posted Jul 09, 2024 - 17:34 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 09, 2024 - 15:06 PDT
Update
We are continuing to work on a fix for this issue.
Posted Jul 09, 2024 - 15:06 PDT
Update
A fix has been developed and tested. It will be deployed shortly, more updates to follow
Posted Jul 09, 2024 - 07:49 PDT
Update
We are continuing to work on a fix for this issue.

Please keep in mind that the form submission and login problems can be avoided by temporarily disabling the app's spam protection feature. This can be done in the admin area of the Customer Fields app under Settings > Security.
Posted Jul 08, 2024 - 17:53 PDT
Update
We are continuing to work on a fix for this issue.
Posted Jul 08, 2024 - 15:02 PDT
Identified
Without notice, Shopify has started to roll out a new captcha service (hCaptcha) for spam protection on storefronts. This is causing a conflict with the app's spam protection feature which uses Google's reCAPTCHA service. Our engineers are actively working on a fix to resolve the issues with form submissions and customer logins. In the meantime, these issues can be avoided by temporarily disabling the app's spam protection feature. This can be found in the admin area of the Customer Fields app under Settings > Security.

Note: These issues are only impacting a subset of storefronts at the moment, but the impact is growing as Shopify's rollout progresses.
Posted Jul 08, 2024 - 12:57 PDT
Update
Embedded forms on storefronts are getting stuck in a loading state upon submission. Customers are receiving errors when attempting to log in. The culprit appears to be a conflict between the separate spam protection features within the app and Shopify
Posted Jul 08, 2024 - 12:47 PDT
Investigating
We are currently investigating this issue.
Posted Jul 08, 2024 - 12:44 PDT
This incident affected: Customer Fields app for Shopify (Customer Fields: Store embeds).