Emails not being delivered to certain mailboxes
Incident Report for Helium Development
Resolved
Our mailer's IP has been fully removed from BRBL and email delivery is now back to normal
Posted 7 days ago. Aug 13, 2019 - 15:05 PDT
Monitoring
Barracuda has confirmed that our dedicated IP has been removed from their block list. We will continue to monitor this issue until we can confirm that all emails are being delivered successfully.
Posted 7 days ago. Aug 13, 2019 - 11:33 PDT
Identified
We are aware of an issue with email notifications not being delivered to certain mailboxes. This issue only seems to affect email addresses that use Barracuda Networks. We are currently working with Barracuda to resolve the issue
Posted 7 days ago. Aug 13, 2019 - 10:35 PDT
This incident affected: Customer Fields app for Shopify (Customer Fields: Email Notifications).