Shopify API access tokens need to be refreshed

Incident Report for Helium Development

Resolved

Our team will continue to monitor for the possibility of any shops that continue to be affected. Affected shops can still log into the Customer Fields app through the Shopify admin to automatically trigger the necessary update.
Posted Jul 01, 2025 - 11:43 PDT

Update

We are continuing to monitor this situation. A small number of shops using the Customer Fields app may still be affected by this incident. Affected shops can log into the Customer Fields app through the Shopify admin to automatically trigger the necessary update.
Posted Jun 26, 2025 - 16:46 PDT

Monitoring

We are continuing to monitor the situation. Shops that are still experiencing access token related problems can resolve the issue by accessing the Customer Fields app through Shopify which will automatically trigger the necessary update.
Posted Jun 25, 2025 - 17:19 PDT

Update

Our team has implemented a fix and will continue to monitor the situation for further errors. Some shops may still be affected and will be addressed as needed.
Posted Jun 25, 2025 - 14:53 PDT

Identified

A security update has been made to the Customer Fields app to update API access tokens. This has caused cases where old access tokens may be causing form submissions or other app functionalities to be failing. Our team is working on updating the necessary tokens, but the problem can also be resolved by accessing the Customer Fields app admin through Shopify which will automatically trigger the necessary update.
Posted Jun 25, 2025 - 12:40 PDT
This incident affected: Customer Fields app for Shopify (Customer Fields: Store embeds, Customer Fields: API).